Hold Back Those Tears, We Have A Forest To Save! – Ori and the Blind Forest by Moon Studios

If Bob Ross Could Program

Ori and the Blind Forest is a beautiful, animated, and challenging metroidvania which educates the player on environmental issues through art. Video games are art no matter what any politician dictates.

This award winning masterpiece developed by Moon Studios and published by Microsoft Studios in 2014 is rated E for everyone must be played by all. I recommend purchasing through Steam and playing with a USB controller to maximize the fun.

The 11 minute intro is a tear-jerker and prepares you for what’s to come in the oncoming hours of playtime. The art direction is done so well I’ll bet it’s hard for you to tell which scenes I am actually controlling Ori and Kuro.

Life is not a Race

Playing through this game can take you  about 4-8 hours for the casual or less than one hour for the speed runner. The main time factor comes into play if you want to unlock 100% or just beat the story line. I would say the average time is about 3-4 hours of non stop gaming if you don’t die that much or get lost exploring the beautiful landscapes.

Take Away

I quite enjoyed this game and it was a very nice break from the FPS/MMO/RPG/MOBAs which I play daily. Non-competitive and relaxing Ori and the Blind Forest won me over with its charming characters and warm illustrative art direction. Two things this game lacked were the that the skill tree really didn’t matter, and that you didn’t get to control other characters later on ala “The Lost Vikings” style. I was hoping to control Kuro and Gumo through more critical points in the game.

Needless to say Ori and the Blind Forest is a must play and I would give it a solid 9/10. For being the first game of Moon Studios, being a unique metroidvania which competes with Rayman and the like, and an affordable PC game which uses a controller. The surreal art direction and musical scores amplify the heart of this game while teaching the younger players how to respect nature.

Fin

I hope you enjoyed my summarized stylistic posting on Ori and the Blind Forest contrast to my philosophical article on The Swapper. As always I will continue to share the gemstones among the sea of downloads until my dna is fragmented and all my telomeres fall off. This is goodbye for now but I will be back in a few weeks. Until next time. Stay true readers.

Moon Studios

Founder: Gennadiy Korol
Founded in 2010
HQ out of Vienna, Austria
Website
Facebook
Twitter
Youtube

 

 

The Swapper by Facepalm Games

A caged god, rocket fuel, and more rocks than Breaking Bad.

The Swapper is an award winning, atmospheric, Sci-fi, puzzler with a philosophical itch lingering even after completion. Created by a very small indie studio who call themselves Facepalm games, they are literally two gents from Finland.

Every bit, nibble and byte of this game was keyed with love, was programmed with thought, intent and passion. The musical composition is pure and induces an ASMR like feel. The entire world, all textures were hand made with CLAY. How cool is that? Even the title screen has a story to tell. Relax, close your eyes, and listen.

Alpha and Doppler, Avocados at Law

 

Choosing to start the game, the initial film and score that pays homage to classic Sci-fi films like Solaris and 2001: A Space Odyssey.  It begins suggesting that the character was forcibly sent away. Banging on the glass and slumping down, realizing his actions are futile. Blast off!!

Jumping to a shot of an orange hued star depicting one similar to our own, the rotating camera shot like Kubrick, the ‘flip’ of realities as the camera does a 180 and the now seen blue hued star all describe the start of something new, a world turned upside down. One of new experiences.

Expanding a bit on what you’ve just seen I’d like to introduce two topics. Science and Greek Mythology. The first I will cover now. My hypothesis is that this fictional game world is based off of Alpha Centauri and the star depicted in the introduction both the orange and blue ones are the SAME STAR. Read more on Doppler shift. A very brief explanation.

Continuing to venture forth through natural pathways, stalactites and rocky formations welcome you but so too does technology. As I pressed X to access the lift it felt like I was accepting a terms of service agreement. The itch has been implanted. One which will drive you mad.

“You have now entered Thesesus Excavation Site 24 on Planet Chori V and all findings are property of the “Sisyphus project”” A recording states.

I’d like to elaborate on this as it is the second topic I said I would expand on, Green Mythology. Read more on Sisyphus once you beat the game, unless you’re the type who eats dessert before dinner. Here a ‘hint’:

“He was punished for his self-aggrandizing craftiness and deceitfulness by being forced to roll an immense boulder up a hill, only to watch it come back to hit him, repeating this action for eternity.”

I suggest playing this game first before you do any more ‘digging’. I don’t run ads on my website, I don’t monetize my videos. I just simply want to share great gaming experiences. This game is worth $15 bucks AND DRM free if you buy it direct from the devs.

Oops there goes gravity

The first item you obtain is the clone gun, you can create up to four clones of yourself. You can create them anywhere within line of sight of the clone guns beam except directly on yourself there are some more variables later as the puzzles get more difficult but this article stops at Transport Gate 1.

Once the “self” clone you are controlling walks into the same space in time as another clone that just mimics your movements, the clone disappears leaving behind only a clone gun, no suit, no body, just…the..gun… AHHHHHHHH.

Another neat feature, as you hold the trigger down before spawning another clone, time slows down.

Progressing through my videos I demonstrate some basic concepts such as max falling height (one story), ‘reclaiming’ your clones, and how to solve a basic puzzle. No need to fret honorary Mensa member, the puzzles get much more difficult.

After completing the four stair equation, you gain entry and pass through the first checkpoint. These checkpoints ‘reclaim’ all clones and also save your state so they make good stopping points when you want to give up and sleep on a puzzle until the next day. I feel these checkpoints are the ‘security measures’ that they installed.

You then run into a log terminal, this one stores a communication from Chori V Excavation Site #24 and the Thesus Xeno Technology Research Facility aka HQ. These logs contain bits and pieces of a story that you can augment into  your theory of what is real, who am I, etc. They are  found all over as you play through the game and are a wonderful add to the story.

Explore my Crevasse

Even though the year is far, far into the future, you will notice how maps somehow are still the centerpiece in navigation. The map in this game resemble ones from any Metroidvania you have played in yesteryear. Doors and areas never visited before are shown, and of course, the friendly “you are here” dot.

A Philo-soul-phical Transformation

The second item you obtain, literally is the title of the game, it allows you to swap your soul/consciousness/control into another clone on the spot in the blink of an eye. (This is where the mental itch gets hotter).  Slowing down time, creating multiple clones of yourself and swapping souls, is the base toolset used to to solve the majority of the puzzles. Before you leave this room, you have probably killed your original self, so I ask you again. What is real?

The other variables are environmental, like the red and blue halogen lights you’ve seen in the video. One blocks the clone gun beam the other blocks the swapper shot.

Continuing on, you will have discovered the first teleporter or as I like to call them, gates. These require “Encryption Orbs” to activate them. Having encrypted data orbs as a currency is pretty rad and spins off another tendril of theories in my head. Who or what wants or uses this data?! Thats the end of my review, rant, theorizing and mini tutorial, after this gate the game gets real.

I feel it’s best experienced yourself.

Buy The Swapper now on Facepalm games website(DRM Free).

Fin

My final gift is the ASMR experience the Credits give.

Facepalm Games

Olli Harjola
Designer, Artist, Programmer, Founder

Otto Hantula
Level Designer

Carlo Castellano
Music, Sound Design, Freelancer

Tom Jubert
Writer, Narrative Designer, Freelancer

Twitter
twitter.com/facepalmgames

Facebook
facebook.com/facepalmgames

Web
facepalmgames.com

VLANS AND TRUNKS HD EDITION

RECESSION AND WIZARDRY

In order to meet the deadline, we had to remove the shouting candidates from the room.

This was done by summoning Trafaldor via IRC, he transcends time and space, and he cast them to another dimension, for now… but never mind that! Please direct your attention to the diagram below.

Do I know that? Requirements: Create 5 sub interfaces(logical) on the router, Create 5 VLANs on the switch, Create a trunk between the router and switch, verify communications between all devices via PING.

Image

FOG OF WAR | (SALLY SHEARS)

Everyone who matters used that cheat. So now use it in real life! Go into the router and get rid of that pesky feature called domain lookup. Go into the switch and do the same.

en
conf t
no ip domain lookup
end
wr

After that lets keep what your typing clear of logging messages so the console doesn’t look like this…sho%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to upw run

en
conf t
line vty 0 [OR] line con 0 
logging synchronous

ROUTE ROUTE FIGHT THE POWAH

Go into the router and turn on Gig0/1, create sub-int 0/1.1, assign an ip address to g 0/1.1 mask is /24

en
conf t
int gi0/1
no shut
exit
int gi0/1.1
encapsulation dot1q 1 native
ip address 10.1.1.1 255.255.255.0

Router interfaces are shut by default so you have to turn them on with no shut. Then we create logical sub interfaces starting with Gi0/1.1. Rinse and repeat for VLANs 2,3,5,7.

int gi0/1.2
 encapsulation dot1q 2
 ip address 10.1.2.1 255.255.255.0
 exit
 int gi0/1.3
 encapsulation dot1q 3
 ip address 10.1.3.1 255.255.255.0
 exit
 int gi0/1.5
 encapsulation dot1q 5
 ip address 10.1.5.1 255.255.255.0
 exit
 int gi0/1.7
 encapsulation dot1q 7
 ip address 10.1.7.1 255.255.255.0
 end
 wr
 

Verify proper sub-interface creation has occurred.

show run
(...)
interface GigabitEthernet0/1.1
 encapsulation dot1Q 1 native
 ip address 10.1.1.1 255.255.255.0
!
interface GigabitEthernet0/1.2
 encapsulation dot1Q 2
 ip address 10.1.2.1 255.255.255.0
!
interface GigabitEthernet0/1.3
 encapsulation dot1Q 3
 ip address 10.1.3.1 255.255.255.0
!
interface GigabitEthernet0/1.5
 encapsulation dot1Q 5
 ip address 10.1.5.1 255.255.255.0
!
interface GigabitEthernet0/1.7
 encapsulation dot1Q 7
 ip address 10.1.7.1 255.255.255.0
(...)

show ip int brief
Interface IP-Address OK? Method Status Protocol 
GigabitEthernet0/0 unassigned YES unset administratively down down 
GigabitEthernet0/1 unassigned YES unset up up 
GigabitEthernet0/1.1 10.1.1.1 YES manual up up
GigabitEthernet0/1.2 10.1.2.1 YES manual up up
GigabitEthernet0/1.3 10.1.3.1 YES manual up up
GigabitEthernet0/1.5 10.1.5.1 YES manual up up
GigabitEthernet0/1.710.1.7.1 YES manual up up
Vlan1 unassigned YES unset administratively down down

SWITCHIN’ LANES

Stand up, breathe and stretch, because we all sit too long without doing so. Now go into your switch and create the VLANs.

en
conf t
vlan 1
exit
vlan 2
exit
vlan 3
exit
vlan 5
exit
vlan 7
exit
do show vlan
VLAN    Name    Status    Ports
---- -------------------------------- --------- 
1       default active   Fa0/1, Fa0/2, Fa0/3, Fa0/4
                         Fa0/5, Fa0/6, Fa0/7, Fa0/8
                         Fa0/9, Fa0/10, Fa0/11, Fa0/12
                         Fa0/13, Fa0/14, Fa0/15, Fa0/16
                         Fa0/17, Fa0/18, Fa0/19, Fa0/20
                         Fa0/21, Fa0/22, Fa0/23, Fa0/24
                         Gig0/1, Gig0/2
2       VLAN0002 active 
3       VLAN0003 active 
5       VLAN0005 active 
7       VLAN0007 active

Now go into each interface and assign the respective interface a VLAN.

en
conf t
int fa0/1
switchport mode access
exit
int fa0/2
switchport mode access
switchport access vlan 2
exit
int fa0/3
switchport mode access
switchport access vlan 3
exit
int fa0/5
switchport mode access
switchport access vlan 5
exit
int fa0/7
switchport mode access
switchport access vlan 7
exit

Verification show run, notice that Int fa0/1 does not have switchport access vlan 1, that is because vlan 1 is currently set to the native vlan, tagging is not used.

(...)
interface FastEthernet0/1
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 2
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 3
 switchport mode access
!
interface FastEthernet0/4
!
interface FastEthernet0/5
 switchport access vlan 5
 switchport mode access
!
interface FastEthernet0/6
!
interface FastEthernet0/7
 switchport access vlan 7
 switchport mode access
(...)

Go into gi0/1 on the switch as we just configured the routers trunk port thus far.

en
conf t
int gi0/1
switchport mode trunk
switchport trunk allowed vlan all
end
wr
 

Now test ping from host to host. Success or not? You decide!

CHALLENGE MODE ACTIVATED!

I’m too young to die – stop VLAN 7 from communicating over the trunk port between the router and switch. Hint – experiment with switchport trunk allowed vlan command
Bronze – Add another host on a new vlan (#) is your choice and verify all hosts can communicate
Silver – Change the native vlan to 11 and verify all hosts can communicate
Gold – Daisy chain switches, add another switch to Gi0/2 and move 3 of the hosts to that switch verify all hosts can communicate
Platinum  – Poll better than Kanye for the 2020 presidential election BRO!

image2.png

Explained: Broadcast Domains and Collisions

88MPH

Let’s take a trip way back to the future,  to a point in time when soldering your own ROM chip, vampire taps and thicknets were hip, when Radio Shack was actually the place to be, at least for people like us.

Businesses ran coax cable for their Ethernet networks. 10Base2(thinnet) and 10Base5(thicknet). Computers would physically access these networks via vampire taps a device which would bite into the cable so bit transmission could occur. Imagine a cat biting an electrical cable.

To connect these runs of coax together a device called a hub was used. Hubs were used for a place ones and zeroes could relax for a nano second and hit the digital car wash, the bits would be cleaned up and sent on their way refreshed. (Boost in signal strength and clarity)

image3.png

A hub so vain it looks in a mirror.

Every message sent in one port of a hub is flooded out all the other ports which is why I relate this process to screaming. Let’s have Donald help us free of charge.

Imagine a small room with 90 yelling Donald Trumps, now laugh…and now cry because you couldn’t work in that environment, and YOU’RE FIRED! Now stop using your imagination, remember you have to go to work on Monday as I’ve crafted this amazing illustration for you.

image4.png

You can see how electrically this would create chaos and lead to CSMA/CD firing over and over. Freezing the network to a crawl.

Because the previous design was hell to support, the bridge was created which reduced the amount of broadcast and collision domains. Bridges are a layer 2 device with logic built in allowing them to record and store information from the frame. This logic and beefed up the hub and by doing so (FIB/CAM) tables were created.

The introduction of the bridge made the hub a paperweight. The FIB / CAM table is  used to keep a short list of interfaces<>MACs. This is similar to how today’s switches work.

Below is a bridge in action, separating devices which in turn reduces the amount of collision domains but allows a single broadcast domain to remain. Each interface on a bridge is its own collision domain.

In the scenario below Cardiff Electric purchased its first bridge with four ports by season 2 they needed A LOT more than that. Therefore each set of three devices (which are vampire tapped in) are in a collision domain but all three interfaces are in one broadcast domain.

image5.png

Hubba Hubba!

  • As hubs progressed they gained more ports.
  • Example: An 8 port hub would connect 8 computers and create a LAN.
  • You have learned: If many hubs were used in a LAN this would increase the potential for collisions especially if you were to network 50 to 100 devices together. DUMB DEVICE LAYER 1

Say ‘what’ again!

  • I consider a repeater a basic signal extender but only for one device
  • A hub also performs the role of a repeater by refreshing and re-transmitting the signal however it has multiple ports
  • A repeater freshens up the signal and sends it on its way. Think of it as a rest stop. DUMB DEVICE LAYER 1

Trebek: You don’t want to burn these…

  • Each interface on the bridge is now a separate collision domain.
  • Fragments your LAN and helps reduce collisions while still allowing all devices to communicate.
  • What is a FIB TABLE?
  • Short list of MACs and Interfaces to know where to forward.
    • This is known as store and forward switching.
  • Each bridge was sold at a uniform speed. All interfaces were either 10BaseT of some variation or FastEthernet there was no mix and match.
  • Fun Fact! Plug and Play didn’t exist yet.
    LOGICAL DEVICE LAYER 2

Switch

  • Higher Port Density, Multi-speed Ports: “Autosensing” 10BaseT, 100BaseT, 1000BaseT. (Mix and Match)
  • What is a CAM Table?
    • Mini ‘database’ storing MAC addresses of devices which are learned from the source ports as they are processed and forwarded on. Review the L2 Header.
    • Reduces collision domains to each interface, by this point, no more vamp taps.
  • Custom control of broadcast domains with use of VLANs
  • Switches of today can look at Layer 3 IP Header and even route!
    LOGICAL DEVICE LAYER 2, Some platforms are LAYER 3!

Level 1 VLANs and Trunking Explained, Dot1q, Politicians and NWO

NEW WORLD ORDER

Imagine a world before we had to make America great again, further back,  ahh, there you go, before the standardization of 802.1q.

In this world, in order to run multiple sub-nets you required separate physical hardware. The more networks you wanted the more routers and switches you had to purchase, install and configure. The alternative was to just have one large and loud network where shit broke all the time like a /16.

AKA

one big happy network

These large networks had a massive flaw. If you plugged in you could hear everyone! That email on its way to the CEO, check. Those tax documents accounting is uploading to the file server, check. (Read my post on Broadcast Domains and Collisions to learn more)

image6.png

Two VLANs by Sea

  • Increase security by separating networks logically
  • Decrease broadcast domains and collisions
  • Reduce hardware costs
  • Experience artisan networks, hand crafted by internet plumbers.

VLANs enable utilizing one physical set of hardware while keeping thousands of sub-nets logically separated.

#realtalk: Accounting employees are now the only ones to see those tax evasions, your customers are separated on their own Guest WiFi vlan, your CEO can share gingerbread recipes with their spouse in private, YOU can login and manage the devices without interruption!

There is one more concept you need to grasp in order for these virtual local area networks to communicate. The art of trunking. Good ol’ 802.1q or as the kids these days say. dot1q. Dotty MCdots. The standard formerly known as Dot.

RULES OF ENGAGEMENT

image7.png

Let’s flesh this network out a bit. You will notice we have added a 1941 and configured the 1Gbit interface on both the router and switch as a trunk, hence the rainbow I painted below.

VLAN tags are located in the L2 header right after the source address. If the 10.1.5.0/24 (Hillary) network wants to communicate with the 10.1.1.0/24(Constitution) network the traffic must leave the switch go to the router and be sent back to the switch.

Remember the following if you don’t remember anything else from this article. All inter-VLAN traffic must transact across the trunk. The routers trunk interface is the gateway for all of these networks. For now just understand the words coming out of my mouth.

image8.png

UNITED

Now that the base concepts have been sworn in,  continue your adventure and read my article on how to configure a network as seen above with a few challenges for you to complete as well. I can’t have all the fun.